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Preface
In early 2007, I used LYX to layout and publish a cookbook on
Lulu.com. A cookbook is a good test of publishing software since
its layout is more complex than a novel but not as difficult as a
brochure or newspaper.
The cookbook is “The Restless Minestrone”, available in the
“Cooking” section of Lulu.com.1 If you look at the preview of the
book, you will see that the combination of text, drawings and
ingredients lists requires a certain level of layout sophistication.
Book design is a difficult art, and it is not likely that it will
be achieved by the average person who uses a word processor.
It is possible to use a word processor to produce a well designed
book, but it is not easy. It is probably not possible unless you are
a trained graphic designer with some experience and knowledge
about book design.
What is required? A good basic design, consistency and
simplicity. Most books produced by a word processor lack the
first two and often the third.
You want to spend your time writing, not worrying about the
layout and design. LYX allows you to do just that. It takes care of
most of the design decisions, producing a book with professional
layout and typesetting. You concentrate on the content.
That is the way it should work.
Alan L Tyree
August, 2007

1

http://books.lulu.com/content/728996
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Some abbreviations
Everything is accessible from menus in LYX, but good touch
typists will want to use key combinations as often as possible.
LYX has many key combinations defined, and in the built-in help
document “Customization” shows you how to add your own.
In this book, we will use the following special keys:
C The control key, usually labelled “Ctrl”
M The “meta” key, usually labelled “Alt” on most PC keyboards
S The shift key
Key “chords” can be represented in print by combinations of
these keys. Some examples:
C-M-Space Hold down the Ctrl and the Meta key while pressing
Space
M-p Hold down Meta while pressing p - gives a list of paragraph
types
You get the idea.

xvii

xviii

The path ahead
This book is not a detailed explanation of how to use LYX. If you
see such a book, ask yourself what good it might be since LYX
has built-in tutorials and user guides that are excellent works. If
you simply want to use LYX, there is no need for any material
other than what comes with LYX.
This book explains why you should use LYX if you are a
self-publisher, and it examines those parts of LYX that are of
particular importance to you as a self-publisher.
So, here is how I propose that we proceed:
• In Chapter 1, I will try to convince you that you should be
using LYX to publish your book. If I fail in this, then you
need read no further.
• If you choose to proceed, I will outline the essential features
of LYX and how you should think about using it.
• For the remainder of the book, I will show you the steps
that I went through to publish this book.
Let’s begin our journey.

xix

xx

Chapter 1

Why LYX?
I know, I know. You have a word processor and you have used it
for years and you are very happy with it and . . .
Stop! You are not only writing a book, you are publishing it
as well. If you sent it to a professional publisher, and if it were
accepted for publication, it would be edited by a professional
editor, designed by a professional designer and set into type by a
professional typesetter. As a self-publisher, you have to do all of
these things yourself.

1.1

Word processor limitations

A word processor might be suitable for writing, but it is not
suitable for publishing. Why do you think that none of the professional publishers produce their books with Word or OpenOffice?
Word processors can produce a good looking product, but it
is not easy. You want proof? Just look at the previews of the
hundreds of books on Lulu.com.1 You can tell which ones have
been produced with a word processor.
Well, maybe not all. If the author is a graphic artist who
knows a lot about book design, then it is possible that he or she
has produced a professional looking book. Is that you? If not,
1

http://www.lulu.com
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then your word processed book is going to look like, well, a word
processed book.
OK, I hear you say, what about desktop publishing tools?
Commercial ones like InDesign or Open Source ones like Scribus.
Surely these can produce a professional looking book.
True. But go back to browsing Lulu.com books. You can
probably spot the ones done with desktop publishing. They will
lack consistency, have too many fonts and too many colours.
The problem with desktop publishing programs is that they
give the amateur too much freedom. And they require too much
from you. They demand that you place every item on the page.
While this might be desirable, indeed, necessary, for a brochure
or a newsletter, it is certainly overkill for your average book.

1.2

Beyond word processing

Ask yourself these questions: “What do I know about book
design?” “What do I know about typesetting?” The most likely
answer, if you are honest, is “Next to nothing!”
If this is you, then you need as much support from your
software as you can get. You need a word processor type program
to help you write your book simply and cleanly. You need software
to help you with the design and typesetting of your book. In other
words, you need software that will replace the professional help
that you would get if you submitted to a commercial publisher.
This is not just my opinion. Consider the following quote
from the Wikipedia article on self-publishing:
Because professional-quality typesetting suites, such
as LATEX, are available as free software, the typesetting of a self-published book may be as good as a
traditionally published work. However, these tools
require some technical skill, and many self-published
works are formatted using a word processor, which
can give less appealing results by comparison. The
development of relatively low-cost desktop publishing
software has put more powerful tools in the hands of
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self-publishers, but without any guarantee that they
will be used to professional standards.
This is where LYX comes in. LYX is your friend. LYX is a good
word processor, but more importantly it will take care of all the
major problems of layout and typesetting. LYX will produce, on
your behalf, a professional layout with better typesetting than
you will get from most commercial publishers. LYX helps to
overcome the problem of “technical skill” mentioned in the above
quotation.
Here is the description of LYX from the LYX website:
LYX is for people that write and want their writing
to look great, right out of the box. No more endless
tinkering with formatting details, ’finger painting’ font
attributes or futzing around with page boundaries.
You just write. In the background, Prof. Knuth’s
legendary TEX typesetting engine makes you look
good.
On screen, LYX looks like any word processor; its
printed output – or richly cross-referenced PDF, just
as readily produced – looks like nothing else. Gone are
the days of industrially bland .docs, all looking similarly not-quite-right, yet coming out unpredictably
different on different printer drivers. Gone are the
crashes ’eating’ your dissertation the evening before
going to press.
LYX can produce, directly in most cases, the PDF file that you
need to submit to your printer for publishing. For more discussion
on this, see the discussion in Chapter 11 on page 61.
LYX is very stable software, but any complex software will
crash from time to time. LYX has one of the best recovery systems
I have ever seen. I have never lost even a single word of text
following a LYX crash, and that included working on a very
unstable system which shall remain nameless.
Are you convinced yet? Wait! There’s more! LYX can also
assist you with professional style cross references, indexes and

4
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bibliographic references. These may not be important if you are
writing a novel, but they are vitally important if you are writing
technical or other non-fiction books. Many libraries will simply
ignore non-fiction books that do not have an index, and any
academic work without these elements lacks credibility.

1.3

Cross references

Cross references are a problem for many writers. In traditional
systems, the writer cannot refer to a page number until the
manuscript is completed and typeset. Even worse, if the writer
decides to reorganise the work, all the cross references become
invalid.
In the past, these problems have been addressed by referring to
paragraph numbers or to section numbers. This allows the author
to insert the cross references before the manuscript is typeset,
but it does not solve the problem of rearrangement, addition
or deletion. And you can be sure that once the manuscript is
rearranged that you will miss some of the existing references.
LYX makes cross referencing easy and foolproof. It supplies a
number of different cross referencing forms such as page reference,
section reference, etc. The important advantage is that the
cross references are automatically updated if the manuscript is
rearranged.2 See section 6.1 on page 32.

1.4

Indexing

LYX will make indexing less of a chore. Nothing can make indexing
easy. It is a painful, time consuming process that nobody enjoys.
Traditional indexing also suffers from the same problems as cross
referencing: rearrangement of the manuscript corrupts all the
former good work and, if index entries refer to page numbers,
then it cannot be completed until the manuscript is laid out and
typeset.
2

LYX is not alone in this capability, but it’s implementation is one of the
easiest to use. This could have gone in the main text, but I wanted to show
you a LYX footnote.
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LYX makes indexing much more pleasurable. An index entry
may be inserted into the manuscript at any time, sub-index
entries are supported and the entire index is recomputed when
the manuscript is rearranged. Section 6.2 on page 33 shows you
how to use the LYX indexing features.

1.5

Bibliographies

Bibliographic references are a constant pain for academic writers.
A bibliographic citation looks like this: see [Lamport, 1994] for a
description of the BibTEX system. The thing about bibliographic
references is that you want them to look exactly the same every
time they appear in your book. Even the most careful writer
will find that there is an annoying lack of consistency in the way
that references are cited when they are entered by hand. Even
the most careful researcher misplaces references, often requiring
hours of work to find them again. The task is just too boring
and too fiddly to be left to the human writer.
LYX uses the BibTEX reference system. References are kept in
a database which is accessed through LYX menus. Citations are
always consistent and the references are always there. Different
citation forms are available and it is easy to design your own.
Unlike some systems, the reference database is contained in a
plain text format. Chapter 7 shows you how to insert citations
and generate a bibliography. If you are an academic writer and
have never used a system such as BibTEX, then you have been
working too hard!

1.6

Should I use LYX for everything?

No. LYX is great when you are writing and publishing a “standard”
book – one with a lot of text and relatively few illustrations. It is
powerful because it takes care of most aspects of design, ensures
consistency, and assists you with indexing and cross-referencing.
It is also excellent for a book like “The Restless Minestrone”
where the illustrations, although numerous, are placed in a reasonably regular fashion. The cookbook also has the advantage
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that recipes form “blocks” of information that may be treated as
more or less independent.
But for some kinds of publishing, the way that LYX imposes
a design is a hindrance. So, for example, if your publication is in
the form of a newsletter, or a picture book, or, possibly, a travel
book, you might be better off with other software.
Here is the test: does each page require customized, detailed
layout and does that layout differ substantially from page to
page? If the answer to this is “yes”, then you will probably need
to use a “desktop publishing” program.
Scribus is an open source software desktop publishing program.
It is very suitable for the kind of book or publication that we
have just been describing. It will require a lot more design input
from you, and if you are not an experienced designer, the final
product will probably show it.
Lyx will do for most kinds of books. As we will see, it offers
the flexibility to mix text and figures in almost any combination.
It will probably do a much better job of layout and design than
you could do. You should consider something else only if your
demands are very specialised and your talents sufficient to carry
it off.3

1.7

LYX summary

There are other programs that can do some of these things, some of
them better than others. However, for the serious self-publishing
author, no other program offers all of LYX’s advantages:
• professional layout of the resulting book
• professional typesetting through the LATEX backend
• easy to use - easier than most word processors
• support for dynamic cross references
3

And even then, you should consider using LATEX. An example is where
you might need multiple indexes. LYX is not too well suited for this at the
moment.
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• support for indexing
• support for bibliographic database and automatic citation
All of these things can assist in making your book look professional
and making your authoring job easier. In short, if you are a selfpublishing author and you are not using LYX, then you are
working too hard.

8
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Chapter 2

LYX basic concepts
LYX looks a lot like an ordinary word processor, but unless you
understand some basic principles you will become frustrated with
it. For example, LYX will not let you put multiple spaces between
words. It simply refuses to respond to your spacing command.
Similarly, it will not let you put extra lines between paragraphs.
It just refuses to do it.
Why? We first need to understand the relation between LYX
and TEX, the typesetting system behind it.

2.1

LYX and TEX

The story goes that Donald Knuth, the great computer scientist,
was disappointed with the typesetting of the second edition of his
work “The Art of Computer Programming”. He decided to write
a typesetting program to correct the deficiency, expecting it to
take a year. In fact, it took ten years and the result was TEX,
pronounced “tek”. It has gone through a number of revisions,
and it is universally acknowledged to produce extremely good
typesetting. TEX is described in Knuth’s own book: Knuth [1984].
One of the strengths of TEX is that it is a powerful programming language. This allows “macros” to be written for regular
tasks. One set of macros is known as LATEX, and these macros
provide a set of instructions aimed at the design and simple

9
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creation of book-type manuscripts. LATEX is described in a book
authored by its creator, Leslie Lamport: see Lamport [1994].
LATEX is a form of text “markup”, and many authors find it
distracting to have the markup in their manuscript. LYX goes a
long way towards solving this problem. LYX allows you to use
the power of LATEX without being bothered by the markup.

2.2

Separation of content and format

It is one of the very basic LYX principles:
As far as possible, the author should concentrate on
structure and content. Layout and typesetting should
be left to the software.
Word processors are designed to allow maximum flexibility in
visual presentation. They allow visual alteration of text and
paragraph properties. That is OK, some say convenient, for short
works, but in a longer work consistency will inevitable suffer.
Professional book publishers use “content authoring” tools.
Each text element is assigned a “style” that reflects its semantic
content. At the end, if the visual output needs to be changed,
then the “style” is altered and all text elements of that style will
be changed.
As an example, consider the paragraphs in this book. The
title of this section “Separation of content and format” is a
paragraph which is intended to be a level two section heading. It
should be assigned that style, and the author should not worry
about whether it is in bold, in italics or any other aspect of the
presentation. The author just marks it as a level two heading and
lets the publisher and typesetter worry about the presentation.
The principle of separation of content is not carried to any
extreme. LYX offers plenty of formatting and layout possibilities,
but they are applied in a systematic way. You will learn some of
these in the chapter on boxes and tables: see page 27. We will
also look at various formatting and layout options as we continue.
However, the basic principle is important and you should not try
to circumvent it.

Self-publishing with LyX
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LYX uses two fundamental concepts:
• each document belongs to a document class
• each paragraph has a paragraph style; the available styles
are determined by the document class.

2.3

The “book” document class

This book is primarily concerned with the “book” document class.
It comes standard with every LYX/LATEX installation. It provides
quite a large number of paragraph types. The paragraph you
are reading now is “standard”, and the five bulleted paragraphs
below are “itemize” paragraphs.
There are other document classes that you might find useful.
Some examples:
• “Article” class for writing journal articles
• “Broadway” class provides paragraph types useful for writing plays
• “Hollywood” for writing screenplays
• “Curriculum vitae” for writing resumes
• “Letter” for writing letters.
Many scientific publishers provide their own document class.
These not only provide paragraph styles but also set out citation
standards, etc.
The “book” class is fairly simple. Authors sometimes want
more “trimmings” on the final product. There are a couple of
book classes that allow you a lot more control over the way
things look. This is done by providing more paragraph styles
for special purposes. The “Koma-script” book class is popular,
particularly with European authors since its default settings are
closer to European publishing conventions. The “Memoir” book
class is also highly configurable. If you have special requirements

12

Alan L Tyree

then you should have a look at these. Both come with excellent
documentation and both are probably included in your TEX
installation.
But the plain old “book” class is good enough for most books.
This book was typeset with it, and it is unlikely that you will
need more. Once you become a LYX wizard you can have a look
at these other classes, but I recommend that you stay with the
simple for the time being.

2.4

Document settings

Overall document appearance is set in the Document → Settings
menu. Figure 2.1 shows the dialogue for setting the document
class. Aside from setting the document class to “book”, there is
nothing more to be done.

Figure 2.1: Setting the document class
Figure 2.2 shows the dialogue for setting up the text layout
for this book. As you can see, most of the settings are left at
“default” although I have made the type size 11pt instead of the
default 10pt.
Page size and layout is set in the Page Layout menu. There
are a number of standard page sizes, but the 6”x9” format of
Lulu.com is not one of them. For custom formats, you must
make sure that the “geometry” package is part of your LATEX

Self-publishing with LyX
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Figure 2.2: The Text Layout dialogue
installation: see page 69 for notes on the installation of LATEX
and LYX on your system.
The other change from the defaults that you should make is
in the “Page layout” dialogue. Make sure that your “Page style”
is set to “empty”. This will prevent the typesetting system from
adding numbers to your pages at this stage. Don’t worry about
this, since we will reinstate them later.

Figure 2.3: The Page Layout dialogue
If you change any of the defaults, click the “Apply” button
to make them take effect on your document.
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The only menu items that are not immediately obvious are
the “Branches” and “LATEX Preamble” ones. We will not use
“Branches”, so it can be ignored. We will add some things to the
LATEX Preamble, but we will discuss that when we come to it.
We will also adjust some margins later, but we will discuss the
details when necessary in Chapter 11 on page 61.
We are now ready to start writing!

Chapter 3

Publishing a novel
Publishing a novel or other plain text work is dead simple using
LYX. This chapter is relevant even if your book is not a novel.
All books have text, and that is what this chapter is about.
For the moment, let’s forget about all that stuff at the beginning of a book (the “frontmatter”) and get right into the body of
it. Chapter 1. The nice thing here is that you don’t even need to
type “Chapter 1”. Just open a new file and choose a paragraph
type of “Chapter” from the drop down menu.
The system inserts “Chapter 1” for you. You can add to that
title if you wish; I have added “Publishing a novel” to the title of
this chapter. Hit “Enter” and start typing the great <American
| Australian | New Zealand | insert name of your country> novel.
Don’t worry about how it looks, just write! Hit “Enter” for a new
paragraph. Note that all the paragraphs that you are writing
here are “Standard” paragraphs.
When you want to start a new chapter, hit “Enter” for a new
paragraph, then go to the drop down menu and choose “Chapter”.
The system will insert “Chapter 2” on your behalf. Hit “Enter”
again for a new paragraph. LYX is smart enough to know that
you probably want a “Standard” paragraph as the first paragraph
in your chapter.
These are probably the only paragraph types that you will
need for a novel. If it is a very long one, you might want to divide
it into parts. There is a “Part” paragraph type provided for that
15
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very purpose. Another possibility is that you wish to include a
quotation. The “Quotation” paragraph type fills the bill:
This is a “Quotation” paragraph. Nicely indented
and set off from the rest of the text. It can be as
long or as short as you wish. When you hit “Enter”
the paragraph type remains “quotation” so the quote
may run for several paragraphs.
When you are finished with the quote, hit “Enter” for a new
paragraph and choose “Standard” from the drop down menu to
return to standard paragraphs.
Although it is unlikely in a novel, you might want to divide
chapters up into “sections” and, conceivably, divide sections up
into “subsections”, etc. Each of these is a paragraph type in the
book class that will insert a suitable heading.
Your novel might even contain lists. For a bullet list, choose
paragraph type “itemize”. For a numbered list, choose “enumerate”. LYX will also do a “dictionary” type list, which LYX calls a
“definition” paragraph type. It looks like this:
Akubra well known Australian hat
Rabbit animal from which Akubra hats are made
Dingo a wild Australian dog
Drongo not a dingo
Once finished with your list, make the next paragraph a “standard”
one and continue writing.
Type enough of your novel to fill three or four pages and then
we’ll take a look at the final product.

3.1

Viewing the typeset text

Let’s look at what we have so far. LYX can produce several
types of output, some of which may depend on your particular
installation. All systems will produce dvi files which are “device
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independent” files. These are intended to look the same on screen
or in print. Your TeX installation will include a dvi viewer.
However, for printing you will probably want another kind of
file. The most common these days seems to be PDF (Portable
Document Format) files. LYX can usually produce PDF files
directly. In fact, most installations have several ways of producing
PDF files. It is likely that the commercial printer who will produce
your book will ask for a PDF file, and it is the preferred format
for publishing on Lulu.com.
So, let’s look at your novel. Go to the “View” menu, then
click on PDF (pdflatex). This will generate a PDF file and open
the PDF viewer on your system. Let’s note a couple of things.
First, the typesetting is first class. Look at it under a magnifier
if your system supports it.
Second, the output is set up for two sided printing. The
outside margin will be a little larger than the inside margin. This
seems counter-intuitive to the beginner, but the idea is that when
the book is opened there will appear to be three more or less
equal white spaces: the outside margin of the left hand (verso)
page, the combined inner margins of the two facing pages, and
the right hand margin of the right hand (recto) page.
These margins may need adjustment depending on the requirements of your printer, but we won’t worry about that for
the time being. These “final touches” will be discussed in Chapter 9 on page 49 and in the chapter on publishing your book,
Chapter 11 on page 61.
Also notice that LYX, actually LATEX has made sure that
your chapters start on the right hand (recto) page, even if it is
necessary to insert a blank page.
The other thing you might notice, depending on the default
settings of your out-of-the-box LYX, is that the pages look a
bit plain. If you have followed my suggestions on page layout,
not only are the pages plain, but they have no folios (numbers).
Most novels have some “headers” and possibly “footers”, and
they certainly have folios. We will deal with this immediately.
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Adding headings

Let’s make the pages look a bit better by adding headers and
folios. A reasonably good style for a novel is to have the author’s
name in the heading of the left hand (verso) page and the name
of the book, perhaps shortened, in the heading of the right hand
(recto) page. To achieve this, we will insert some LATEX code at
the beginning of the text.
Don’t be afraid. Go to the very beginning of your text. Go to
the Insert → TEX Code menu or click on the TEX icon. A small
box with red lettering will appear with a space for you to insert
material.
Type the following inside the box:
\mainmatter \pagestyle{myheadings}
\markboth{your name}{your title}
This can be all on one line, split over several lines or over several
TEX boxes. Of course, you should substitute your actual name
and title.
Let’s look at the results. Go to the View menu, but this
time click on Update and then PDF (pdflatex). Depending on
the PDF viewer that you are using, the result may update itself
automatically, may require you to do something (C-r on my
viewer) or it may open a completely new viewer. Worse, you
may have to exit the viewer and then restart it. This latter
behaviour is most annoying, but it has to do with the viewer that
you use, not any setting that LYX can control. It seems to be a
problem mainly for Windows users: see Section 12.2 on page 69
for suggested alternatives.
If you have done everything correctly, you should see headings
similar to the ones in this book. Folios (page numbers) appear
on the outside top edge, and name and title are set in italics on
the inside of the headings.
Another common heading structure is to have the folios in
the headings along with a chapter title on the left hand page
and a section title with folio on the right. This is obtained by
changing the LATEX instructions given above to:

Self-publishing with LyX

19

\mainmatter \pagestyle{headings}
This may be preferable where the book is more technical. Indeed,
it may have been a more appropriate choice for this book.
It is possible to get much fancier headings. Most LATEX
installations include the package “fancyhdr” which will allow you
to define three part headers and footers for even and odd pages.
LYX contains a pagestyle option to utilise the fancyhdr package,
but you still have to insert LATEX code to get it to work properly.
The “Memoir” and “Koma-script” book classes also have facilities
to do this. My own preference would be to use one of these more
complex book classes if you need more flexibility in designing
headers and footers. But since you are doing your own publishing,
why not stick with the simple style for the time being?

3.3

I

Dropped caps

f you look at a work of fiction, you will often see that the
first paragraph of the chapter or of a section has a “dropped”
first letter. It looks like the first letter of this paragraph. To
do this simply, you need to have the “dropping.sty” package in
your LATEX installation or be willing to add it. See the discussion
at Chapter 12 on page 69. It is also possible to do in “plain tex”,
but if you are a beginner, you probably don’t want to do this.
For the stout hearted, the “Extended features” document that
you can access through the “Help” menu has an example on how
to do it.
So, how did I make the dropped cap? In the Documents →
Settings → Latex preamble menu, type \usepackage{dropping}.
Then at the place where you want the dropped cap, use the
menu Insert → Tex. This will give you one of those red boxes.
Inside the box, put \dropping{3}{I} to get the dropped cap of
the previous paragraph. The “3” says that you want it to extend
over three lines and the “I” is the letter that you want put there.
You can have more than one letter if you like, but it doesn’t look
too hot.

20

Alan L Tyree

A word of caution here. The “dropping” command does not
play well with pdflatex on many systems. Try it with yours, but
if you get an error, as I did on my system, it is probably because
of this inconsistency.
The “fix” is to change the package declaration in the preamble.
Go Document → Settings → Latex Preamble and change the
entry to:
\usepackage[dvips]{dropping}
Note the different style of brackets in the declaration. This should
allow you go generate PDF files directly with pdflatex.
We should note here that there are a number of different
display formats. The “dvi” format is standard on every LATEX
installation. It stands for “device independent” files, meaning
that they should look the same in print and on the screen. The
PDF format should also have this quality, but PDF readers vary
greatly in their ability to present PDF files.
For reasons that will become apparent in Chapter 11, the
postscript format is also important. Very high quality printers
process postscript files directly, and they may also be reliably
converted to PDF files.

3.4

Final touches

Once you have finished typing and editing your novel or other
text book, you need only add the “front matter”. This is discussed
below at page 41. This will probably give you all you need to
submit your manuscript for printing, but if you are really picky
about things, you will also want to read the chapter on “Fine
tuning”: see Chapter 9 on page 49.

Chapter 4

Adding pictures
Most books other than novels will have some illustrations or
pictures. In this brief chapter, I will show you how to include
graphic illustrations. LYX can handle a wide variety of formats.
My own view is that the png format is best for black and white
illustrations. Most colour pictures will be in jpeg format. LYX
easily handles both for PDF or postscript output. There should
be automatic conversion to other formats if you choose dvi output.

4.1

Inserting a graphic

It is easy to insert a picture or other graphics into your LYX
manuscript. Go to the Insert → Graphics menu. Figure 4.1
shows the dialogue box that pops up. There are several things to
note about this.
First, you have the option of showing the graphic in your LYX
screen. You will ordinarily want to do this. The trouble is that if
the picture is large, your screen will be very full and cluttered.
Scale it down by the appropriate amount. I often set the scale
factor at 10% since that means that the graphic is visible but it
doesn’t take up much real estate on the screen.
The “Output” part of the dialogue governs the size of the
image in the final typeset manuscript. This is something of a
trial and error exercise. Note that there are a number of ways
of setting the output size. I normally make it a percentage of
21
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Figure 4.1: The graphics menu
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the textwidth or column width and click on the “Maintain aspect
ratio” button. You can also rotate the graphic if you so desire.

4.2

Floating a graphic

The problem with simply inserting a graphic is that it might
mess up your page breaks, sometimes to a degree that is catastrophic. Remember that the idea of LYX is to leave layout to the
typesetting software. You concentrate on the content.
The way to do that for graphics is to use a “float”. The
float construct allows the LATEX typesetting program to make
the decision about the exact location of the graphic. All of the
pictures of menus in this book are floats of png graphics files.
Go to the Insert → Float menu or click on the appropriate icon.
There are several options there, but we will only be concerned
with the “Figure” option for the moment.
This will insert a “float” in your manuscript. There will be
a “Figure #:” inside the box. Now you want to insert a graphic
inside the box. There is a slight detail here to consider: if you
want the caption to be below the graphic, you must first press
“Enter” to get a new paragraph inside the box. Put the graphic
in that position. If you are happy to have the caption above the
graphic, just insert it at the end of the box. Type in a caption
for the graphic in the space following the semicolon.
The other problem might be that the graphic is set to one
side or the other. Place the cursor in the paragraph where the
graphic appears, go to Edit → Paragraph Settings and center the
paragraph. Each of the graphic floats in this book is centered in
this way.
Floats may appear above, below or even on the next page
of the location where you inserted the float. Don’t refer to “the
diagram below” or any such phrase. Put a label in the float, right
after the “Figure #:”, and then insert a cross reference to it in
your main manuscript: see Chapter 6 on page 31 for a discussion
of labels and cross references.
You can exercise some control over where LATEX puts the float.
Right click inside the float box and make a choice from the menu
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that pops up. The best choice here, if you are not happy with
the results, is “Here if possible”. If you force the position to be
“Here definitely” then you might as well not use the float. Just
insert the graphic into your text. I don’t recommend this, but it
may be necessary or desirable in certain unusual cases.

4.3

Text Wrap Floats

There is another kind of float that is
nice to use sometimes, usually when the
float is more of a decoration than an essential part of your exposition. The text wrap
float allows your text to “flow” around the
Figure 4.2: A text graphic. By right clicking in the box, it
wrap float
is possible to exercise a certain amount of
control over the placement of the float.
It seems that you should place the float before the text that
you want to wrap around since it sometimes starts a new paragraph.

4.4

Graphics requirements

You should talk to your printer about graphics requirements
such as resolution and whether it should be black and white or
grayscale. Do this at an early stage of your book so that you
don’t have to repeat a lot of work later. If you don’t yet know a
local printer, then follow the rules for publishing on Lulu.com.
If you are publishing with Lulu.com, there is a wealth of information on preparing your graphics. Most importantly, images
should be scanned or entered at 300dpi. If your book has colour in
the main body, then black and white images should be grayscale
with a gamma of between 2.2 and 2.4.
I used grayscale images in ”The Restless Minestrone” even
though the book was entirely black and white. The results were
good.
There is a slight problem with screenshots. The basic screenshot is normally 72dpi. If printed as part of a PDF file, it will
appear fuzzy. The solution is to rescale the graphic using some-
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thing like the GIMP or Photoshop. Using the GIMP, Image
→ Scale Image and rescale to 300dpi. Set the Interpolation to
“None (Fastest)”. This should give reasonably good images in the
printed product.
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Chapter 5

Boxes and tables
Boxes are treated by the typesetting system as a single unit, just
as though it were a single letter. Boxes can be of any size, but
they will never be split across lines or pages. This is both a
strength and a weakness, for there is nothing to warn you that a
box is too big.

5.1

Minipages

In spite of this problem, boxes are extremely useful for layout and
formatting. For example, we may wish to put two graphics side
by side. In a cookbook, we will often want a list of ingredients
and a graphic to appear side by side. Boxes are your friends in
this case. Here is an example of a list of ingredients and a graphic
from “The Restless Minestrone”:
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• 1 large cauliflower
• 1 onion, chopped
• 1 cup whole milk
• 1 1/2 teaspoons white
vinegar
• 2 tablespoons butter or
margarine
• salt and pepper to taste
• chopped parsley

This was constructed by putting two boxes side by side. They
are each 45% of the column width, and I have left-aligned the
paragraph. Both boxes are “middle” aligned.
There are several different kinds of boxes, but the only one
you need to know is the “minipage”. A minipage is treated just
exactly as though it were a separate page. A variation on the
theme is a “Shadowbox”. Here is an example which also shows
how footnotes are treated:
This is a “shadowbox”a minipage
with a column width of 50% and
aligned at the “top”.
a

Choose from the menu by right
clicking on the box.

I put the box on the right side of the page by inserting a
“horizontal fill” to the left of the box. A horizontal fill expands to
fill as much space as necessary. The box is a little tight against
the previous paragraph. This could be fixed by using a small
vertical space above the box, but I have left it as an example to
be dealt with later: see the Chapter on “Fine tuning” at page 49.
Right clicking on the inserted box allows you to choose from
the box menu. Most of the items are self-explanatory, but the
“alignment” options may be confusing.
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“Top” aligns the top of the box with the text line on which
the box is inserted. “Bottom” and “center” align, respectively,
the bottom of the box or the center of the box with the line.
Here are two boxes, one top aligned and the other bottom
Bottom
aligned
aligned: Top
box
. I have framed these boxes to give a
aligned
box
better visual indication of how boxes work. Notice that the boxes
are too close to other text and to each other. They should be
separated with spaces as described in the chapter on “Fine Tuning”
at page 49. These boxes are also very narrow at only 10% of the
column width.

5.2

Tables

Tables, like graphics, should usually be floated. They are handled
well by LYX, but it is wise to plan carefully what you want in
your table before entering it in LYX. Both tables and floating
tables can be inserted from the menus or from the toolbars. Like
graphics floats, the table float provides room for a caption. As
with graphics, if you want the table to appear above the caption,
press and “Enter” first to make a new paragraph above the caption
and put the table there.
You can put text in tables
If you want

2.4
35.1

Table 5.1: Sample table
If the table is a very long one so that it is likely to spill over
into later pages, then you should specify that it is a “longtable”.
This is done in the table menu which, as usual, is obtained by
right clicking on the table. The sample table, was placed using
the “Here if possible” option on the float table.
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Chapter 6

Cross references and
indexes
Cross referencing and indexing are never easy. In the old days,
these two tasks were extremely unpleasant. Even worse, they
could not be completed until the “page proofs” were returned
to the author. Since this was late in the book production cycle,
the task was done under pressure accompanied by many cups of
strong coffee.
Some book publishers attacked the problem with numbered
paragraphs. By using a notation like [2-55] to refer to paragraph
number 55 in chapter 2, the author could insert cross references
and index items which referred to the target paragraph rather
than to the page number. This allowed the author to perform
these tasks during the authoring stage of the book rather than
at the page proof stage.
The numbered paragraph solution helped, but it still meant
that the insertion or deletion of material meant that the cross
references and index entries had to be reviewed and changed.
Errors inevitably followed.
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6.1

Cross references

Modern word processors have made the cross referencing task
easier. Most of them support some form of “label” which is
the target for the cross reference. OpenOffice.org, for example,
has a “Cross-reference” dialogue which is under the Insert menu.
Abiword and Microsoft Word have similar functions.
LYX has a simple and easy to use cross referencing system.
A “label” is a mark in the text that identifies the point where
the label is inserted. In the LYX document window it shows up
as a small button with the name of the label printed on it. A
label may be inserted by using the Insert → Label menu, but it
is easier to click on the little tag-like icon in the toolbar. A label
dialogue appears which provides a suggested label.
The suggested label is “smart” in the sense that it is context
sensitive. A label inserted immediately after a section or a chapter
will look like “sec: some word” or “ch: some other word”. For
example, there is a label in this manuscript just after the title
“Cross references”. The label suggested automatically by LYX is
“sec:Cross-references”.
To make a cross reference, use either the Insert → Crossreference menu or the icon on the toolbar which looks like a book
with an arrow on it (or something like that!). Whichever way you
do it, a cross reference dialogue will pop up giving you choices
of the type of cross reference that you would like to insert. First
choose the label that you wish to refer to, then click on the drop
down format box. This will give you a choice of reference types.
Here are several examples of cross references to the label at the
beginning of this section.
• Here is a plain <reference> cross ref: 6.1
• The (<reference>) style cross ref doesn’t work here. See
the explanation below.
• Here is a <page> style cross ref: 32
• Here is a “on page <page>” style: on this page
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• Here is a “<reference> on page <page>” style: 6.1 on the
preceding page
• And here is a “Formatted reference” style: Section 6.1
As you can see, each of these produces a slightly different form
of cross referencing and requires a different form of “lead in”.
The “on page <page>” style is interesting and very useful. It
will normally produce output such as “on page 72”, but it cleverly
knows when the reference target is on the same page, the next
page, on the preceding page or on the facing page and adjusts its
output accordingly.
In all cases, the author no longer has to worry about the
location of the target of the cross reference. LYX, actually LATEX,
keeps track of the location for you.
The (<reference>) type is confusing and slightly misleading.
It inserts a LATEX command \eqref{}. This is not listed in the
LATEX reference, and it does not compile when exported to a
LATEX file. The easiest way to deal with it is to leave it alone.
Don’t use it.
I also note that the “Formatted reference” depends on the
existence of the prettyref.sty package. If this is not installed on
your TEX system, then it will not work in LYX. It is included in
most TEX installations.
As an extra navigation feature, right clicking on the cross
reference button in LYX will take you to the target label in the
manuscript.

6.2

Indexing

Indexing a long document like a book is a difficult task at the
best of times. Like cross referencing, the old way was to wait for
the arrival of page proofs, then use a stack of index cards to make
entries and note page locations. Since the publisher was always
in a hurry to get the corrected page proofs back, the procedure
was not very pleasant.
As with cross referencing, using paragraph numbers as the
basic unit allowed the author to do the indexing at an earlier
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point in the process. Insertion or deletion of new material made
a mess of everything.
Some word processors include indexing abilities, but they tend
to be clumsy and inefficient to use. LYX has one of the best.
First, let’s talk about the indexing process. There are essentially two ways that a book can be indexed. First, the author
should make index entries early in the authoring process. At this
stage, the indexing should closely follow the heading structure of
the text.
So, for example, in writing this chapter, I should index the
terms “cross reference” and “index” at an early stage of writing.
This will provide a basic index to the work.
The second stage of indexing will usually occur when the work
is finished. Usually, the author will go through the text and find
words that should be indexed.
But merely indexing words will seldom be an adequate approach to indexing. If it were, the whole process could be mechanised. A look at some indexes will convince you that the mechanical process gives a bad index.
So, the final stage of indexing is to look for “concepts” that
need to be indexed. These may need to be indexed even though
there is no corresponding word in the manuscript.
LYX makes all this as easy as possible. Go to the menu Insert
→ Index Entry or click on the toolbar icon that looks like a little
set of filing folders. A small “Index” button will appear. Click
on the button to see the index entry. If inserted at the end or
the beginning of a word, then that word will appear as the one
indexed.
So, for example, let’s index a word that won’t appear anywhere
else in this book. The word is xxxyyy and I clicked on the index
icon immediately after typing the nonsense word. Check in the
index of this book, and you will find that the word is indexed to
the proper page.
Of course, it is not necessary to insert the index entry immediately when typing. You can insert an index item anywhere.
Just click the index icon when the cursor is at the beginning or
the end of the word that you want to index.
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If you want to index a phrase or combination of words, select
the phrase in question and then position the cursor at the end
of the selection. Clicking the index icon will then index the
combination of words.
If you want to index a concept, then you will need to fill in
the index entry by hand. Suppose I want an indexing entry for
“Indexing procedures”, but I don’t actually have that phrase in
my text. Click the indexing icon at the point where you think the
index entry should point to. You will then have to click on the
Idx button, erase the entry there and put “Indexing procedures”
in its place. I have put an “Indexing procedures” entry at the
beginning of the first paragraph on page 33.
Although the LYX documentation does not mention it, you
can also do “hierarchical” indexing. So, for example, under
the heading “Index”, I might like to have subheadings “words”,
“phrases” and “procedures”. The Idx buttons for these will be
Index!words, Index!phrases and Index!procedures respectively.
You can see how these appear in the index of this book.
Finally, to make the actual index appear in the book, go to
the end of your manuscript. Go to the menu Insert → List/TOC
→ Index list. This will insert an Index button into the LYX
manuscript which will be used to generate your index when the
document is compiled. The index will begin on a new page at
the end of the document.
It’s not easy, but if you have ever done it the old fashioned
way you will think that Christmas has come early!
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Chapter 7

Bibliographic references
LYX uses the BibTEX system of storing bibliographic references.
BibTEX allows you to store all your bibliographic references in
a single database which is then referenced by a “key”. If you
have never used BibTEX or a similar system for storing references,
then you are simply working too hard. BibTEX allows you to
enter a reference once only and, almost as important, to cite it
consistently throughout your work.
BibTEX can produce a number of different style bibliographies.
Set the type you want in Document → Settings → Bibliography.
If you are using a standard Linux distribution then you will
probably have the BibTEX system installed as part of your TEX
authoring installation. Similarly, if you are using Windows, then
it should be installed as part of the LYX standard installation
procedure. See Chapter 12 on page 69 for the discussion of
installation.
If you know nothing at all about BibTEX, then you should
probably read Appendix B of [Lamport, 1994]. Note that this
citation was inserted in accordance with the instructions of this
chapter.
Don’t be afraid! A BibTEX entry is simple once you get the
knack of it. Here is an entry from my BibTEX database:
@Article{tyree99:_legal_natur_elect_money,
author = {Alan L Tyree},
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title = {The Legal Nature of Electronic Money},
journal = {JBFLP},
year = 1999,
volume = 10,
number = 4,
pages = {273--281}
}

A citation to this looks like this: [Tyree, 1999].1 It will now
appear in the Bibliography at the end of the book.
You can create and maintain a BibTEX file with any text
editor, but it will help to have a specialised tool. If you know
Emacs, there is a BibTEX mode that makes entry and maintenance
particularly easy. The above BibTEX entry was made using Emacs.
The key is chosen automatically.
Pybliographer is a Python based tool for manipulating bibliographic databases including BibTEX. For Windows users,
WibTEX is a graphical front end that allows you to create and
maintain BibTEX files, and also interfaces with MS Word. KBib is
a bibliography reference manager for the KDE desktop. BibDesk
is an OS X program for Mac users. Each of these programs work
well with LYX. See section 12.4 on page 70 for details on how to
get these programs.

7.1

Using BibTEX

Assuming that you have your BibTEX database established, go to
the end of your document and then Insert → List/TOC → BibTEX
Bibliography. A button will appear in your LYX manuscript, and
a dialogue will pop up.
Click on Add to add a database to your document setup.
You should add the name of your BibTEX file without the .bib
extension. The “Style” determines how your citations will appear
both in the text and in the bibliography section. If you are
1

Using the Natbib and the Author-year style. I don’t know if it is a bug
in version 1.4.3, but I had to put a \bibliographystyle{plainnat} in the LATEX
preamble to get this to work right.
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writing for a particular publisher, they may require certain styles.
Some publishers have their own BibTEX style files which can be
installed into your TEX installation.
Since this book is about self publishing, there is no need to
worry about changing the default styles. The default is “plain”
and it produces the results that you see in this book. I think it
is worthwhile adding the Bibliography to the Table of Contents
which you can do by clicking the button in the dialogue.
It is also possible to make your own style file with an utility
called makebst. It is easy to use and you can experiment with
various bibliography formats. This will be useful if some established publisher decides that your book should be published by
them. The nice thing here is that nothing needs to be changed
except the style file that you specify for the bibliography.

7.2

Inserting citations

Once you have the bibliography file set up, inserting a citation
is as simple as using the menu Insert → Citation or, as usual,
clicking on the citation icon. I can’t describe the citation icon
since this is a place where a single word is worth a thousand
pictures. Just check your toolbar and find the icon that inserts
citations and commit it to memory.
The Add-citation dialogue, see Figure 7.1 on the next page,
shows you a list of keys down the left side and the appropriate
bibliographic entry on the right. The BibTEX database can be
searched by keyword in the “Find” space. The search can be by
regular expression if you know how to use these. If you don’t
know, you should learn. The search is over all fields of the BibTEX
database, not just the keys shown on the left.
Once you have found the entry you want, click to add it. The
LYX citation dialogue will show you the way that the reference
will appear in the bibliography: see Figure 7.2 on the following
page. There are certain adjustments that you can make, including
placing some text before and after the citation. When you are
satisfied, click “Apply”.
That’s it!

40

Alan L Tyree

Figure 7.1: The Add-citation dialogue

Figure 7.2: The citation dialogue

Chapter 8

Front matter
Look at the first few pages of a professionally produced book.
This is the so-called “front matter”, and there is a fairly standard
sequence of pages. The “folios”, i.e., page numbers, will normally
be lower case roman. The first few pages will not contain folios
although they are counted.
The front matter consists of title pages, copyright pages, tables
of contents and figures and other elements to be discussed below.

8.1

The first four pages

The very first page of a book is usually the “half-title page”.
The page is very simple, containing only the main title of the
book. It does not contain the sub-title, the author or any other
information. The page has no folio. It is sometimes said that the
original purpose of this page was to protect the main title page.
The reverse of the half-title page, the first verso page, may
contain printing history or series information if the book is one
of a series. Most often, the page is blank.
The third page of the book is the title page. It is a recto page
and contains the full title of the book, the author or editor and
the name of the publisher at the bottom of the page.
The fourth page, the verso of the title page, is the copyright
page. It contains the copyright notice for the publication, the
printing and publishing history, and the ISBN/CIP (Cataloguing41
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in-publication) information. It is common for this page to be
printed in a smaller type.

8.2

Remaining frontmatter

These four pages appear in almost every professionally produced
book. In addition to these four pages, there may be a dedication
page which appears as recto, and the verso of this page is blank.
If these pages appear, they are also unpaginated.
The remaining pages of the front matter contain folios. The
first of these will be paged as “v” or as “vii” depending on whether
there is a dedication page. The following list of elements are
common front matter material:
• Table of contents
• List of figures
• List of tables
• Foreword
• Preface
• Acknowledgments
• Introduction
• Abbreviations
It would probably be unusual to find all of them in a book. A
novel might not contain any of them, but most books contain
some of them. When they do appear, their order is somewhat
arbitrary. The foreword is usually written by someone other than
the author, preferably a person who carries some authority in
the field. The preface is written by the author and will usually
contain some information about why the book was written. The
preface also usually contains some more personal remarks than
would appear in the body of the book.
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The introduction may be part of the front matter, but it is
perhaps more common to make this the first chapter of the main
text. I have put an introduction in this book, but titled it “The
path ahead”.
LYX is helpful here since it can build a the first three items
automatically.
I do not find LYX to be particularly helpful in building the
first four, six if you include a dedication, pages of the front matter.
There is a “Title” paragraph style, but it seems inflexible in what
it produces. It is really better to “handcraft” the first four pages
pages. The following describes the process that I use for building
the initial pages.

8.3

Handcrafting the title pages

First, we do not want folios on the first four pages or the first
six pages if there is a dedication. I have found that the best way
to accomplish this is to go to the Document ->→ Settings →
Page Layout menu. Go to the Page Style drop down menu and
choose the “empty” page style. If you have followed my earlier
instructions, then you have already done this.
You can design your own title pages if you like, but the title
pages of this book are more or less standard. I’ll explain the
construction of the title pages for this book.

8.3.1

The half-title page

The first page is the short title page. It begins with a \frontmatter
command at the very beginning of the manuscript. Use the
Insert → TEX Code menu or the TEX button on the toolbar.
This ensures that when folios do appear, they are small Roman
numerals.
I then followed it with a vertical space from the Insert →
Special Formatting → Vertical space menu. I used a vertical
space of 2 inches. This is obtained by choosing “custom” from
the drop down menu. You must click on the “protected” button
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in the dialogue box. This is because vertical spaces are ignored
at the beginning or end of a page unless they are “protected”.
Type in your title, highlight it and choose the text style button
from the toolbar. Make your title big and bold, then follow with
a page break (Insert → Special Formatting → Page break). You
should either centre the title or make it right justified: use the
Edit → Paragraph Settings menu.

8.3.2

The half-title page verso

The next page, the “verso” of the short title page, should be
blank. To be safe, put something non-printing on it. I inserted
a “protected space” by typing C-space. Sometimes LATEX is so
smart that it leaves out a completely blank page, so we fool it
with the protected space. Follow this with another page break.

8.3.3

The title page

The next page is the full title page. I put a couple of horizontal
lines on either side of the title and author (Insert → Special
Formatting → Horizontal line). This is followed by a vertical fill
from the Insert → Special Formatting → Vertical space dialogue.
Vertical fills are “rubbery” lengths that fill up as much space as
they can. The publisher information at the bottom is a centered
paragraph with a line break, C-Enter, after the first line. In
this book, I right justified the title and author as well as the
horizontal lines: use the Edit → Paragraph Settings menu.

8.3.4

The copyright page

The next page, the verso of the full title page, is the copyright
page. I did a left flush paragraph at the top which describes the
publisher and copyright information. Each line ends with a line
break inserted by typing C-Enter. Then put in a vertical fill.
This is followed by the “Open source” paragraph that describes
the software used, then another vertical fill. This in turn is
followed by the “Creative Commons” paragraph and another
vertical fill.
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The final paragraph is the Cataloguing-in-publication entry
obtained, in my case, from the Australian National Library. See
the chapter on ISBN and CIP at page 55 for information on the
CIP process. The paragraph has a number of line breaks.
Notice that the effect of the three vertical fills is to put
equal spaces between the paragraphs. Vertical fills split the
available space equally between themselves. I have sometimes
heard vertical fills described as “compressed air” spaces. This is a
nice description and illustrates how the fills result in a vertically
centered paragraphs.
Follow this with a page break and that is the end of the first
four pages of the front matter. A nice touch is to make the
copyright page appear in slightly smaller type: highlight all the
text on it and then click on the “text style” button on the toolbar.

8.3.5

The remaining frontmatter

The remainder of the front matter is to some degree a matter
of choice. Again, I will describe the material at the front of
this book. The dedication page is a simple one line paragraph
preceded by a “protected” vertical fill and followed by the same
thing, resulting in a vertically centered paragraph. Make the
paragraph horizontally centered by using the Edit → Paragraph
Settings dialogue or calling it up from the toolbar icon.
The table of contents is inserted from the Insert → List/TOC
menu. This just puts a button in your manuscript that says
“Table of Contents” on it. There is a minor glitch here: the
Table of Contents will begin with a numbered page, “vii” in this
book, but then the numbers disappear again. The fix is easy:
immediately before the Table of Contents button, insert another
TEX command, namely, \pagestyle{plain}. That will reinstate
folios as the default for remaining pages.
While you are in the neighbourhood, you might as well add
the buttons for the List of Figures and for the List of Tables.
There is no need to hand-craft page breaks here since the system
automatically begins these on a new page.
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Now is a good time to look at another preview of your book.
Generate the preview and then have a look at the pages of your
frontmatter. If the first four pages are OK, then have a look at
the table of contents. The table is generated from the headings
in your document. If you have a lot of lower level headings, then
the table may appear cluttered. Not a problem! Go to Document
→ Settings → Numbering and TOC. There you will find sliders
that allow you to adjust the level of headings that will appear in
your Table of Contents.
As long as you have the preview there, notice also that the
first four pages, six pages if you have a dedication, have no folios,
but that the table of contents has a “vii” at the bottom and the
small roman numerals continue on each page. Just as we wanted!
The “Preface” title is a “Chapter*” style paragraph. “Chapter*” style paragraphs are not numbered nor do they appear in
the table of contents. It does have the effect of beginning the
preface on a recto page.
I think you get the idea now. Pages in the front matter will
be numbered with small Roman folios until LATEX encounters the
\mainmatter command. It will then switch to Arabic folios which
will be placed according to the pagestyle that you have chosen.
I should mention again that if you use one of the extended
book classes, “Koma-script” or “Memoir”, then you will have
more options for layout. However, for beginners, the normal book
class does everything you need and more. As you can see from
this book, it provides a very professional looking book layout
with minimum effort.

8.4

How to make very long titles readable
in the table of contents

I have made the title of this ridiculously long to illustrate the
point. The title is so long that it would look ugly in the Table
of contents. LYX provides you with a method to overcome this
embarrassment.
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Immediately after typing the long title go to Insert → Short
title. This inserts a small button labeled “opt” where you can
type in a “short title”. The heading will appear in the Table of
Contents with the “short title” instead of the ridiculously long
title.
If you check in the Table of Contents of this book, you will
see that I used “Long titles” as the short title for the ridiculously
long title of this section.
As a side benefit, the short title will appear in the Navigate
menu, making it easier for you to find your way around your
document.

8.5

List of figures

Making an index of the figures in your document could not be
easier. First position the cursor in the frontmatter at the place
where you want the table to appear. Go to the “Insert” menu,
then to “List/TOC”. Choose the “List of figures” and a button
appears that is similar to the Table of Contents button. Time
for another preview!

8.6

List of tables

You should know how to do this by now. Position the cursor in
the frontmatter at the point where you want the list to appear.
Go to Insert → List/TOC → List of tables. A button will appear
in your manuscript, and when you do a preview of the document,
you will see a list of tables at that point.
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Chapter 9

Fine tuning
When you have finished, really finished, your book, you will
want to go carefully through the PDF file to find things that are
not quite right. In this chapter, we will look at some common
problems that you might face, and the tools available to deal
with them.
First of all, you probably don’t need to do anything. LATEX
is a very clever typesetter. Some of the things that we are going
to look at in this chapter will improve the looks of your final
product, but not by much. Unless you know exactly what to look
for, chances are that you would never notice that they can be
improved.
I cannot emphasise strongly enough that you must not do this
until you are absolutely, positively, no-more-excuses finished with
the writing of the book. We are going to be putting commands in
the text that alter the final appearance, and if you change even
one word of the manuscript you may need to start all over again.
So, under penalty of death, do not even read this chapter
until you are finished with your book. Really finished. Got it?

9.1

Widows and orphans

Widows and orphans are single lines of paragraphs that appear
at page breaks. One line of the paragraph is on one page, the
rest of the paragraph is on a different page. It doesn’t look right.
49
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An orphan is where the line is on the bottom of one page with
the remainder of the paragraph at the top of the next. A widow
is the opposite: the body of the paragraph is on the bottom of
one page with the widow at the top of the next. There is a cute
little mnemonic to remember which is which:
A widow has a past, but no future. An orphan
has a future, but no past.
Generally speaking, LATEX is very good at avoiding widows and
orphans, but it will occasionally slip up. You can improve LATEX’s
performance here with a command in the preamble. Use:
\clubpenalty=10000
\widowpenalty=10000
If you are having trouble with widows and orphans, then this is
your first step. Make a new preview and have a look. Chances
are that your problem will have disappeared. If not, read on!
Orphans are easy to deal with. Just enter a page break before
the beginning of the paragraph.
Widows are harder to handle. There are several possibilities,
and there is no telling ahead of time which is likely to work best.
The two main strategies are:
• Make a little more space on the bottom of the first page,
thereby making space to accommodate the widow on the
first page; or
• Make a little less space on the bottom of the first page,
thereby forcing the penultimate line onto the next page.
The first strategy will work if you have space on the first page to
play with. This was often the case in my work with the cookbook.
It will also work when you have one or more sectional titles on
the page.
Implementing the strategy calls for inserting a small vertical
negative space on the page. “Negative space”??? Yes. The
argument in the vertical space dialog does not need to be positive.
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Putting in a small negative argument will often free up enough
space to accommodate the widow. Since we are attempting to
make space for lines, I recommend using “ex” as the unit of
measurement. Try “-.5ex” first, then preview. Depending on the
contents of your page, you might be able to use a couple of these
at different points.
A second, and possibly better, way to “enlarge” a page is to
use the following TEX command:
\enlargethispage{\baselineskip}
Depending on your installation, it may be necessary to put this
command between two paragraphs of the page that you want to
enlarge.
The second strategy is probably your best if your first page
is largely text. In that case, you don’t have much in the way
of blank space to play around with. Try putting small positive
vertical spaces after each paragraph.
If these tricks don’t work, then my advice is to rewrite the
offending paragraph or forget about it and accept the widow or
the orphan. Since you are self-publishing, the choice is up to you!

9.2

Protected spaces, thin spaces.

There are several circumstances that trick LATEXinto doing the
wrong thing. For example, the LATEX code that I entered in
the last sentence. There is no space between the “LATEX” and
the “into” in the sentence. This is so even though I put a space
between the code entry and what comes after, it does not show up
on the final printout. The solution here is to use an “interword”
space. This inserts a space between the code and the following
word that will be respected by LATEX. It appears on the screen as
a small blue open box. You can insert an interword space from
the Insert menu or by using the C-M-Space key combination.
Interword spaces are useful in another context. English usage
is to put more than a single space between sentences. When
LATEX sees a punctuation mark followed by a space, it thinks that
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it is the end of a sentence. However, that is not always the case.
Abbreviations are a case in point. Sometimes we write e.g. as an
abbreviation for “for example”, but we want a normal interword
space after the “g.”. The solution is to use an interword space
after the “g.” so that LATEX isn’t fooled. That is what I have
done in the sentence above.
There is another common situation where you want to ensure
that two words are not split across lines. What you need is a
“protected space”, essentially a hard-coded space that is outside
the rules of LATEX. LATEX will not allow the words on either side
of a protected space to be run together or to be split between
lines. So, for example, in expressions like 3 kg (short for “three
kilograms”) or s 14 (short for “section 14” in legal writing), you
do not want LATEX to split the line between the “3” and the
“kg” or between the “s” and the “14”. If the words are in the
middle of a sentence, then the protected space looks just like an
ordinary space, but if they would be split at a line break, then
LATEX adjusts its rules to keep them together. The way to get the
protected space in LYX is to use the Insert menu or the C-Space
key combination. It appears on the screen as a small red open
box.
There are other circumstances where a full space after a full
stop (a period for my American readers) is too much. For example,
in writing the name of an author with initials. Consider:
A. L. Tyree
Because the punctuation is followed by a blank space, LATEX
gives the space after the initials the same space it would give to
the end of a sentence. We could use interword spaces:
A. L. Tyree
That is better, but it still appears to be too much space.
Thin spaces are spaces which are half the size of normal
between word spaces. Here is the author’s name using thin
spaces:
A. L. Tyree
That is probably the best that we can do. Thin spaces may
be inserted via the Insert → Special formatting menu or the
C-S-Space key combination.
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Is this worth the effort? Probably not unless you just like to
fiddle with typesetting. Would you have ever noticed the different
spacing in ordinary text? Probably not, but there is a certain
satisfaction in getting it just right.

9.3

\raggedbottom

LATEX attempts to keep the text height even on each page. That
way, when you open a book flat, the text on each page appears
to be equal sized rectangles.

Figure 9.1: Default layout
Boxes and other non-breaking text blocks sometimes cause
this spacing to look strange. The problem occurs in this book
on page 27. Because the list box and the graphic box cannot be
split across pages, there is too little text on the preceding page.
How should this text be arranged? In the original version of this
book, it appeared as shown in Figure 9.1.
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I don’t like that spacing. One solution is to put \raggedbottom
in the LATEX preamble. This stops LATEX from forcing equal text
blocks and gives the page the form it now has.
Neither solution is entirely satisfactory, but it is not really
A
a L TEX problem. A human typesetter would have to make the
same decisions, probably with the same outcomes. I like the
current layout a little better, but it really is personal choice.
Since you are self-publishing, it is your choice!

9.4

Spacing around boxes

I find that text following boxes sometimes seems to be cramped
against the boxes. This was a problem, for example, on page 28.
The paragraph beginning “This was constructed...” was not
separated enough from the “chopped parsley” list entry. It is easy
to fix this by putting a small vertical space before the paragraph
in question.
I would normally have put a small space before the shadowbox
on the same page, but I have left it in its raw state to illustrate
the problem.
The fix is simple. Go to Insert → Special formatting →
Vertical space. In the drop down dialogue, select “Smallskip” or,
if you prefer, “Custom”. If you decide to put in a custom vertical
space, I suggest that you use the “ex” as your unit. One “ex” is
the length between baselines and so is a natural unit to use to
make small vertical spaces.

9.5

Don’t do it much

Don’t do much fine tuning. It can be absorbing and very, very
time wasting. Chances are that the output from LYX will be
satisfactory right out of the box. You may be able to find some
things such as we have discussed that can be improved, but you
have to ask yourself if the improvement is worth the time involved.
Most of your readers will never notice.

Chapter 10

ISBN, CIP and
Copyright
Unless your book is just for family and friends, you should get an
ISBN for it. Without an ISBN you can forget about your book
ever being sold by bookstores or purchased by libraries.
Cataloguing-in-publication is a service offered by some national libraries. The CIP entry is what your book catalogue
“card” will look like, or would look like if libraries still used cards
instead of computer entries. By supplying the information during
publication, you are able to include it on the copyright page.
If you look at the bottom of the copyright page of this book,
you will see the CIP entry for this book. Unfortunately, some
countries restrict the publishers who may submit books for CIP.

10.1

Getting an ISBN

An ISBN is an “International Standard Book Number”. An ISBN
is a unique identifier for your book, and is available only from
an authorised agency in your own country. To find the agent for
your country, visit the web site:
http://www.isbn-international.org/en/agencies.html.
The details of pricing and availability differ from country to
country. For example, at the time of writing, Australian ISBNs
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may be purchased individually or in blocks of ten. In the USA,
you cannot purchase individual ISBNs. The smallest block is one
of ten.
The purpose of an ISBN is to identify one title or edition of a
book. If you put out a new edition which is significantly different
from the previous one, that is, it is not just a reprint, then it
requires a new ISBN. The ISBN system allows efficient marketing
of products by booksellers, libraries, universities and others. Now
you see why an ISBN is important if you expect anyone else to
deal with your book.
The ISBN system is relatively new. It originated in the United
Kingdom with the large booksellers and stationers W. H. Smith.
The original was a 9-digit code which was later adopted an an
international standard by the ISO, the International Standards
Organisation. The ISBN was expanded to a 10-digit code, the
last number being a “check digit”.
Since January 1, 2007 the ISBN has been 13 digits. The code
consists of
• a three digit prefix
• a group identifier code which groups countries sharing the
same language
• a publisher identification code
• a title identification code and
• a single check digit.
The number of digits assigned to each of these groups might
vary. A large publisher may have a small group assigned to the
publisher identification code which leave space for a larger number
of title codes.
For those of you who are interested, the check digit is assigned
as follows: using the first 12 digits, multiply each digit alternately
by 1 or 3. Add the results up modulo 10, giving a result from 1
to 10. If it is 10, replace it with 0. The result is the check digit.
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The purpose of a check digit is to catch elementary transpositions. The one just described catches most, but not all. The old
10 digit ISBN use a procedure which was then summed modulo
11. Since 11 is prime, the “blind spot” doesn’t happen.
The ISBN should be printed on the copyright page. If you
are going for a CIP, then you need to supply the ISBN on the
application form.
The ISBN should also be printed on the back cover and, if
you are going to do it right, be accompanied by a bar code for
automated scanning. If you are publishing with Lulu.com (see
Chapter 11), then a bar code will be added automatically. If you
are arranging your own printing, you will need to generate your
own bar code. There is software available for doing this, but you
can also do it on line at:
• http://www.tux.org/~milgram/bookland/ or
• http://www.terryburton.co.uk/barcodewriter/generator/.
If you don’t feel confident about generating your own bar code,
there are commercial outlets which will do it for you, but the
process is simple and you should explore the free option before
paying out your hard earned money.

10.2

National Library CIP

Most national libraries will accept a Cataloguing-in-Publication
application from independent publishers. The US Library of
Congress is a notable exception. For some inexplicable reason,
the Library will only provide the free service to major publishers.
It will not provide the service at all to individual new publishers.
I can’t help you here. I suggest that you write to your political
representative and ask them to explain why a taxpayer funded
service goes only to the rich.
For the rest of us, check out the web site of your national
library. You should find instructions on applying for CIP. The
purpose of CIP is to provide cataloguing information for inclusion
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on your copyright page. The cataloguing information is then
made available to booksellers, libraries and others.
You can see an example of CIP by looking at the copyright
page of this book.

10.3

Legal deposit requirements

Most countries require a book published in that country to be
deposited with the National Library. Political sub-units such as
states and provinces may have a similar requirement.
The so-called “deposit libraries” are charged with preserving
the material deposited with them for the use of future generations. A further benefit is that the deposited materials normally
serve as the basis for national bibliographies as well as other,
more specialised, bibliographies. These bibliographies are widely
distributed both nationally and overseas.
Also, the CIP process is not completed until such time as the
deposit copy is received. This is important for those of us who
live in those countries where the CIP procedure is available to
the little guy.

10.4

Copyright

There is widespread confusion about copyright. Most importantly,
it is NOT necessary to apply for copyright. You have copyright in
your book as soon as it is written. There is no formal procedure
necessary.
There is, however, a minor formal procedure which is necessary
to protect your work in some (not all) countries. You should
have, on the copyright page, a phrase similar to “ c 2007 <Your
name>. All rights reserved.” If you do not reserve all rights, the
statement should be modified accordingly: see the example on
the copyright page of this book.
How do you get the “ c ” symbol? Insert → Tex Code and
then type \copyright in the little box. Don’t forget to put an
interword space after it: C-M-Space.
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Copyright protects the expression of an idea. It does not
protect the idea. In particular, if you have a very clever plot for
your novel, copyright protects the expression of that plot, that is,
the words of the novel. It does not protect the plot. I can come
along and write a book with exactly the same plot so long as I
do not use your words.
Copyright is personal property. It may be sold or inherited.
You should consult the appropriate legislation in your own country
to see precisely what rights are granted by copyright in your
jurisdiction, but commonly you have the exclusive right
• to reproduce the work in a material form
• to publish the work
• to perform the work in public (very important for plays!)
• to broadcast the work and
• to make an adaptation, e. g., a screenplay of your novel, or
a translation
These are your rights to do with as you wish. You may sell them.
You may die and leave them to your relatives or others named in
your will. You can even give them away, either partly or in their
entirety.
Because of the rise of Free and Open Source Software (FOSS),
copyright licences have been developed which are similar in spirit
to the GPL used in licencing software. This book itself is licenced
under a Creative Commons licence which permits you to copy
and distribute it without seeking my permission provided you do
not do so for commercial gain and provided the work remains
“attributed” to me. Since I am writing and publishing the book
using FOSS, it is a way of returning some value to the community
that has made it possible and to whom I owe so much.
That is my choice, but you are not bound by it. For your
own book, you may use the FOSS and still retain full rights and
powers as granted to you by the copyright legislation in your
jurisdiction. It is your choice.
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Chapter 11

Publishing your book
First of all, let’s be clear about what it means to publish a book.
The publisher is not the author, the editor, the designer, the
typesetter or the printer of a book. Some of the parties mentioned
in the previous paragraph may actually be the same person, and
since you are interested in self-publishing, most of them will be
you.
Publishing is a business, even if sometimes a very unprofitable
one. The publisher is the person who takes the risk, who organises
the production of the book and arranges for its distribution.
Self-publishing, in its strictest sense, means that you do all
these things. This doesn’t mean that you need to do all of them
directly. You will almost certainly use a commercial printer to
produce and bind the books. You may pay someone to assist in
the design of a cover or in the distribution of the book. But you
are in charge. All of the decisions are yours. You reap the profits
(good luck!) and wear the losses.
You must distinguish self-publishing from “vanity publishing”.
In vanity publishing, you pay for the process but have no control
over it. Avoid vanity publishing as you would the bubonic plague.
It is expensive, and the contracts inevitably impose no obligation
on the publisher but to provide you with a few author’s copies.
The four colour ads are seductive, but you will, most likely,
end up with nothing but these copies which will have cost you
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many, many times what you could have obtained them for by
self-publishing.
There have always been self-published books, but the advent
of the computer has changed everything. It is now possible for
the author to present a manuscript which is well designed and
typeset at a professional standard. That is important, but for
our purposes it is equally as important that the computer, in the
form of digital printing, now permits cost-effective short print
runs. Indeed, it may be cost-effective to print a single copy of a
book, the so-called “print on demand” (POD).
Black and white books will be much, much cheaper to produce
than texts with colour. The difference, for example, between a
cent or two per page and fifteen to twenty cents per page.
We will look at a couple of the more common options: using
a local printer and publishing on Lulu.com.

11.1

Local printers

I used a local printer for the Australian edition of “The Restless Minestrone”. My advice and comments are based on that
experience.
First of all, talk to your printer at an early stage of your
project. It will be important to know what size paper may be
used and how the printer wants the final manuscript and art work.
It is almost certain that the printer can deal best with a PDF
manuscript which is why I have emphasised that output in this
book.
Available book sizes will depend on your location. Most of
the world uses the international A and B series of paper sizes.
B5 is 176mm x 250mm and is a good size for many books. It is
the size that I used for the Australian version of “The Restless
Minestrone”.
The USA tends to use other sizes. A popular size for novels
and other books is 6in x 9in which works out to be 152.4mm x
228.6mm. That is the size that this book uses since Lulu.com
does not offer a B5 option, and it is the size that I used for the
Lulu.com version of “The Restless Minestrone”.
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You local printer will also advise on margins and, in particular,
what “gutter” you need. The gutter is an additional margin on
the inside of each page to account for the part of the book that is
“lost” due to binding. Some printers will make that adjustment
for you so that you don’t need to change your manuscript.
Talk to your printer about binding and covers. The two
common forms of binding for paperback books are “perfect” and
spiral. Perfect binding essentially glues the pages and covers
together. It is suitable for novels and other books that will be
read more or less from beginning to end. For reference books
or other books where you want to refer to a page while doing
something else, spiral binding is preferred since the book will
open flat. I used spiral binding on “The Restless Minestrone”
since a cookbook is usually used for referral while cooking. A
computer manual might be another good candidate for spiral
binding.
One advantage to using a local printer is that he or she is
likely to want the book to look as good as it can. After all, the
finished product is as much a work of the printer as it is of the
author/publisher. This interest means that the printer will help
you at each step to produce a high quality product. You can talk
to your printer about the quality of paper, its color and other
aspects of the production.
The disadvantage of using a local printer is that you will
probably need to have a decent size print run. 500 is likely to be
the smallest print run that will give you a decent break in prices,
and even at that the price is likely to be close to that of a POD
supplier.

11.2

Lulu.com

Lulu.com offers print on demand publishing to authors at a
reasonable price. You are perhaps more limited in the paper sizes
and textures, but the advantage is that the process is automated
and hassle-free. Lulu.com offers genuine self-publishing as well
as a couple of “distribution services”.
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Distribution services

Lulu.com, at the time of writing, offers “self-publishing”, “Published by Lulu” and “Published by You”. The first service is free,
and Lulu.com does not call it “self-publishing”. Their description
of this service is that you use Lulu.com as the sole retail site for
your work. This is not entirely accurate, since you may order
multiple books from Lulu.com and use them in any way you like.
In particular, you may sell them through bookshops or your own
web site.
“Published by Lulu” is a fee-based service. Lulu.com is the
publisher of record, and they obtain the ISBN for your book.
Lulu.com has arrangements with Amazon, Barnes & Noble and
other retail outlets.
“Published by You” has you as the publisher, which entails
obtaining your own ISBN, but makes use of Lulu.com’s retailing
and distribution connections. According to the web site, the
service allows you to register to become your own publisher and
purchase your own ISBN from the US ISBN agency. You also
obtain a listing in the wholesaler’s catalogue. The “Published by
You” service is only available to residents of the USA, US Virgin
Islands, Guam and Puerto Rico.
Of course, there is nothing to prevent you from applying
directly to the ISBN agency for your own ISBN anyway.

11.2.2

Lulu marketplace

Lulu.com calls the self-publishing option the “Lulu marketplace”.
You are in complete control of setting up your book. You may use
your own ISBN if you have one (I recommend that you get one),
and the book is available for on-line purchase at the Lulu.com
website. The procedure for getting your book printed is simple
since Lulu.com has a “wizard” that takes you through the process.
Lulu.com says to leave at least .5 inch margins and recommends a “gutter” of .2 to .3 inches. For coil bound books, the
gutter recommendation is .375 inches. LATEX uses very generous
margins in the book class so it may not be necessary to specify a
gutter.
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After some experimentation, I used custom margin settings
for “The Restless Minestrone”. You set these in the “Margins”
dialogue of the Document → Settings menu. These were:
• Top: 2.5cm
• Bottom 2.5cm
• Inner: 2.5cm
• Outer: 2.0cm
To give you an idea of how that looks, I have used the same
margins for this book. For a perfect bound book, you might
even consider increasing the inner margin to 3cm or so, about 1.2
inches. The nice thing about publishing on Lulu.com is that you
can experiment at very modest cost.
Covers pose something of a problem. You can use a standard
cover chosen from the Lulu.com gallery. These are generally very
high quality, but you can expect to see other books with covers
just like yours (except for the title, of course).
I don’t think that LYX is suitable for making covers. I used
the GIMP (the Gnu Image Manipulation Program) for the cover
of “The Restless Minestrone”. You can see that at the Lulu.com
website.1 The GIMP is available for GNU/Linux systems and for
Windows. The commercial equivalent is Photoshop which a lot
of Windows users seem to have. You could also use a desktop
publishing program such as Scribus or Adobe InDesign. Lulu.com
requires covers to be in the PDF format.
In any case, when making the cover, be sure to follow the
guidelines on the Lulu.com web site. These guidelines give the
exact pixel measurements that your cover should have. Follow
these faithfully and you should have no problems. Getting the
colours exactly right is something of a hit and miss procedure
unless you have a very sophisticated workstation.
1

http://books.lulu.com/content/728996
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Lulu.com MS requirements

LYX produced PDF files are printed faithfully by the Lulu.com
printing partners. The body of this book was produced on a
Debian GNU/Linux system using LYX with the pdflatex output.
“The Restless Minestrone” was printed from a LYX produced PDF
file, both on Lulu.com and at a local Australian printer.
However, if you wish to use one of the Lulu.com distribution
services, Lulu.com says that the PDF file must be produced by
the Adobe Distiller. I have no idea why this requirement exists,
but I must accept that it is a genuine requirement.
You can buy a copy of the Adobe Distiller if you wish. It is
not cheap, but perhaps you have other uses for it that make it
worthwhile.
If you do not wish to purchase the software, do not despair.
Lulu.com will produce a PDF file for you from a number of
different formats. The format that we should use, as LYX users,
is the postscript format. Postscript files are “printer ready” as
they stand, but Lulu.com will convert it to a PDF file that is
acceptable under their distribution agreements.
You must take some care with this conversion process. It
should go flawlessly and, indeed, the few trials that I have made
have proceeded without pain. But there is risk with any conversion process that something will come out the other side that
doesn’t look quite right. In other words, examine the final PDF
product very carefully and make sure that it is a faithful conversion.

11.3

Other POD publishing

Lulu.com does not have a monopoly on POD publishing. In
fact, it doesn’t even do its own printing, instead using a service
called Lightning Source. That company will not, however, deal
with individuals. This is not an overwhelming obstacle if you are
willing to establish your own business, but that is a subject for a
different book. If you are interested in pursuing this, I suggest
that you read the excellent “Aiming for Amazon” Shepard [2007].
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A number of other POD services exist, but they are often
coupled with some form of publishing agreement. These may
provide more or less the same services as a normal commercial
publisher, but often they appear to have the flavour of a vanity
press. Approach with caution.
POD services will proliferate as the machines come down in
price. Shop around.

11.4

Pricing and marketing

What price should you set for your book? A lot depends on how
you intend to market it. You must realise that short print runs
or POD means that your book is going to cost more to produce
than it would if produced by a big publisher with a print run of
thousands.
If you are going to market through bookstores, then you need
to know that they will expect a very healthy discount from the
retail price. My experience has been that a 30% discount is
acceptable to local bookstores, but my reading suggests that 40%
and more might be expected in other places. You have to take
this into account when you are thinking about the retail price of
your book.
A rule of thumb for traditional marketing is to double the
production cost of your book. This gives you the “elbow room”
to offer the substantial trade discounts that will be required.
If you are willing to market only through on-line markets,
then you may be able to get along with a lower markup. On-line
marketing is not easy, but it is relatively cheap if you don’t count
your own time.
A safe approach is to price your book at twice the production
cost, but then sell on-line at substantial discounts. In a way, this
is the best of both worlds, but the local bookstores that have
taken your book may have a darker view of it.
Marketing your book is like marketing any other product.
You will have to work at it, swallow your pride, and try to think
of novel ways of getting it out there. Good luck!
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Chapter 12

Getting and installing
12.1

Linux

LYX is dead easy to install on any of the major Linux distributions.
For Debian based systems, use apt-get, aptitude or synaptic to
install the LYX package. You will also need the packages for the
texlive system.
RPM based distributions are no more difficult. I have no
direct experience with these, but each comes with LYX and
texlive packages. Install in your usual way.
I had only one issue with my initial installation. LYX uses
the geometry.sty package to alter page and margin sizes. I found
that the basic TEX installation did not contain that package. The
problem was easily fixed by making a full TEX installation.

12.2

Windows

LYX has a very good installer for the Windows system. Using
the standard LYX installer will ensure that you get LYX as well
as a full Miktex TEX installation. Get the latest installer from:
ftp://ftp.lyx.org/pub/lyx/bin/.
Most Windows users will have the Adobe Acroread PDF
reader installed. This is a very good reader, and it is the one
which probably gives the truest picture of your manuscript. It
is not, however, a good viewer to use with LYX since it does not
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have a “reload” facility. When you refresh your preview of your
manuscript, you must actually exit Acroread and then restart it
to see the fresh view. I am told that the latest LYX has scripts
which do this automatically. You might find that satisfactory,
but if you have an older/slower machine, you probably should
consider alternatives.
Windows users on the LYX user mailing list have suggested
several alternatives. I cannot comment on the relative merits,
but here are a few suggestions:
• Foxit:
http://www.foxitsoftware.com/PDF/rd_intro.php
• SumatraPDF:
http://blog.kowalczyk.info/software/sumatrapdf/
SumatraPDF has been recommended as very quick which is
important if you are doing frequent update previews.

12.3

Apple

LYX is only available for the OS X systems. Get the latest
software .dmg file from:
ftp://ftp.devel.lyx.org/pub/lyx/bin/ and install as normal. You
need to install a TEX system. MacTEX is recommended: see
http://www.ctan.org/tex-archive/systems/mac/mactex/.
See the Mac group on the LYX Wiki for more information.

12.4

BibTEX managers

For BibTEX managers, the following are recommended:
• For Gnome based systems, Pybliographer. Install from your
distribution packages or from the home web site:
http://pybliographer.org/.
• For KDE desktop systems, KBib. Install from your distribution packages or from the home web site:
http://user.digisurf.com.au/~thachly/kbib/.
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• For Windows users, WibTEX. Get from the home web site:
http://www.wibtex.de/.
• For OS X users, BibDesk. Get from the home web site:
http://bibdesk.sourceforge.net/.
• For any system: Emacs with BibTEX mode.

12.5

Resources

The LYX user mailing list is informative and very friendly. Join
by following the instructions at the LYX web site:
http://www.lyx.org/internet/mailing.php.
The LYX Wiki will answer a lot of your questions and is full
of useful tips and tricks see:
http://wiki.lyx.org/LYX/LYX.
If you publish on Lulu.com, have a look at the forums which
are informative and helpful. Lulu.com’s website is a maze of
FAQs and helpful hints.
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